Back to overview
Degraded
API degraded
May 6, 2026 at 12:18pm UTC
Affected services
Global API
Resolved
May 6, 2026 at 12:25pm UTC
The intermittent 504 Timeouts have been resolved. We will further monitor it and investigate the root cause.
Affected services
Created
May 6, 2026 at 12:18pm UTC
We are seeing 504 Errors on the Challenge API. We are investigating the root cause.
Affected services